Monitoring AWS Service Disruption

Incident Report for StrongDM

Resolved

As of 3:53 PM PDT this issue was resolve according to AWS. More information can be found here: https://health.aws.amazon.com/health/status this issue appears to be resolved.
Posted Oct 20, 2025 - 23:00 UTC

Monitoring

We’re aware of an ongoing issue with AWS that may impact some StrongDM US Control Plane customers. While this is not a StrongDM issue, we are actively monitoring the situation and will provide updates as needed.

For more information, please refer to AWS’s status page: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 16:08 UTC
This incident affected: US Control Plane (Admin UI, API).