SDM Admin UI is down.

Incident Report for StrongDM

Postmortem

Summary

On October 21st, 2025, StrongDM experienced an outage affecting access to the Admin UI across multiple Control Planes. The issue began shortly after a planned update and lasted approximately 30 minutes before service was fully restored.

What Happened
Prior to the incident, Control Planes were operating on Admin UI version 116.27.0. Around 12:00 PM PDT, a code change was deployed that unintentionally disrupted replication between internal systems responsible for propagating updates across Control Planes.
At 12:45 PM PDT, Admin UI version 116.28.0 was released as part of a routine update. Due to the earlier replication issue, this new version was not consistently distributed to the Control Planes. This inconsistency caused components of the Admin UI to become unavailable.
The outage lasted for approximately 30 minutes while the team identified the replication issue, restored consistency, and validated recovery.

Resolution
Engineering corrected the replication pathway and ensured all Control Planes received the appropriate version updates. Normal service was restored once consistency was re-established.

Prevention & Remediation
To prevent this issue from occurring again, StrongDM engineering has implemented additional validation and safety checks in the release process to ensure that updates are properly replicated before becoming active.

Posted Nov 14, 2025 - 20:45 UTC

Resolved

At this time Admin Access to the UK control plane has been restored.

If you are still having issues connecting to the StrongDM Admin UI reach out to StrongDM Support https://help.strongdm.com/hc/en-us/requests/new
Posted Oct 21, 2025 - 20:36 UTC

Update

The Admin UI's for both the US and EU control planes have been restored. We are still working on restoring service to our UK control plane.

Updates to follow.
Posted Oct 21, 2025 - 20:30 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 19:58 UTC

Identified

StrongDM is aware of an issue with the Admin UI not loading. The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 19:58 UTC
This incident affected: US Control Plane (Admin UI), UK Control Plane (Admin UI), and EU Control Plane (Admin UI).