High load/degraded performance

Incident Report for StrongDM

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 23:15 UTC

Monitoring

We have found and resolved the issue affecting the US control plane. Estimated impact on performance was approximately 6 minutes. We are continuing to monitor affected systems.
Posted Jul 03, 2025 - 22:31 UTC

Investigating

We're currently investigating an issue that is causing degraded performance for some users. We will provide further updates as they become available.
Posted Jul 03, 2025 - 22:21 UTC
This incident affected: US Control Plane (Admin UI, API).