Routing Issues
Incident Report for StrongDM
Postmortem

At 16:04 UTC, September 8th, we made an enhancement to our routing protocol for compatibility with a new operating mode, which caused the current routing system to fail. The change has since been rolled back, and the issue identified to be resolved. As of 16:48 UTC, September 8th, full functionality has been restored.

In response to this we will be augmenting our monitoring processes for new version rollouts, ensuring we can react to these kinds of changes more quickly.

Posted Sep 08, 2023 - 22:01 UTC

Resolved
We made an enhancement to our routing protocol for compatibility with a new operating mode, which caused the current routing system to fail. The change has since been rolled back, and the issue identified to be resolved. The service should be functioning normally at this time.
Posted Sep 08, 2023 - 16:57 UTC
Investigating
Some organizations may experience connection issues. We are currently investigating the issue and will update here with additional information.
Posted Sep 08, 2023 - 16:45 UTC
This incident affected: API.