SDK: Service Degradation
Incident Report for StrongDM
Resolved
DNS has successfully propagated and all systems are operational.
Posted Oct 01, 2021 - 00:04 UTC
Update
strongDM has identified the source of the SDK degradation as an expired certificate issued by Let's Encrypt. strongDM has released remediating steps to update the DNS records and issued requests to DNS providers to refresh relevant entries. strongDM is awaiting DNS propagation.

If any customer wishes to accelerate their ability to use our API before DNS propagates, please reach out to support@strongdm.com for a workaround.
Posted Sep 30, 2021 - 18:57 UTC
Update
Remediation steps to push a new certificate CA to our production servers. This may cause a service outage of a few minutes.
Posted Sep 30, 2021 - 18:05 UTC
Update
Further remediation steps are being investigated
Posted Sep 30, 2021 - 17:49 UTC
Identified
Remediation steps are being initiated which we expect to result in a service outage for a few minutes.
Posted Sep 30, 2021 - 17:31 UTC
Investigating
strongDM has identified a known issue that seems to be related to Let's Encrypt certificate expiration. strongDM is actively remediating.
Posted Sep 30, 2021 - 15:48 UTC
This incident affected: API.