StrongDM Slack Integration is experiencing issues currently.

Incident Report for StrongDM

Resolved

This issue has been resolved.

The cause: The SKU of certain customers was miscalculated by the Slack integration, resulting in affected customers losing functionality. A code change will be pushed out to make fix this issue.
Posted Jan 15, 2026 - 19:32 UTC

Monitoring

We have rolled back to a previous version and the Slack Integration should now be working.
If you are still having problems related to our Slack integration please reach out to Support: https://help.strongdm.com/hc/en-us/requests/new

We are monitoring the situation.
Posted Jan 15, 2026 - 19:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 15, 2026 - 19:01 UTC

Investigating

Investigation has started. Updates to follow. At this time the only StrongDM component impacted is our Slack Integration.
Posted Jan 15, 2026 - 18:57 UTC
This incident affected: US Control Plane (API), UK Control Plane (API), and EU Control Plane (API).