Increased Latency and Intermittent Timeouts in US Control Plane (Admin UI & API)

Incident Report for StrongDM

Resolved

We have identified the root cause for the elevated latency and intermittent timeout errors which were affecting the US control plane (app.strongdm.com). There should be no further service-impacts as a result of this event. Engineering is taking steps to prevent such occurrences moving forward, and will provide an RCA within the next 7 days.
Posted Feb 17, 2026 - 23:28 UTC

Update

Status Update – Performance Investigation

Engineering has rolled back the recent change, and we’ve observed improvement in latency metrics.

However, other performance indicators have not shown the same level of improvement.

We are continuing to actively investigate the issue to determine the underlying cause. Some incremental improvements may still be observed as we proceed with analysis and mitigation efforts.

Look for further updates here.

A full Root Cause Analysis (RCA) will be provided once we have identified the cause and implemented a confirmed fix.
Posted Feb 17, 2026 - 19:27 UTC

Investigating

We are currently investigating elevated latency and intermittent timeout errors affecting the US control plane (app.strongdm.com). Customers may experience slow load times in the Admin UI and delayed or failed/slow API requests.

Our engineering team is actively working to identify the root cause and mitigate the impact. We will provide an update as soon as more information is available.
Posted Feb 17, 2026 - 15:42 UTC
This incident affected: US Control Plane (Admin UI, API), UK Control Plane (Admin UI, API), and EU Control Plane (Admin UI, API).