System email provider is currently inoperable

Incident Report for StrongDM

Resolved

We have implemented a resolution with our system email provider and the issue should now be resolved.
Posted Apr 20, 2023 - 16:26 UTC

Investigating

We are having an issue with our system email provider. This impacts password reset emails and other account-related emails. We are currently working towards a resolution and will provide further updates as soon as possible.
Posted Apr 20, 2023 - 15:43 UTC
This incident affected: Admin UI and API.